Myphoner - Trouble sending email via Microsoft accounts – Incident details

Trouble sending email via Microsoft accounts

Resolved
Degraded performance
Started 12 months agoLasted about 3 hours

Affected

Web Application

Operational from 6:49 AM to 6:49 AM, Degraded performance from 6:49 AM to 9:54 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    All issues around sending email are now resolved and emails are sending again. Users should NOT have to refresh their email connections, but in case there are further error messages the email connection in question will have to be refreshed/reconnected. We are now monitoring the situation to make sure everything is back to normal.

  • Identified
    Update

    Our prior quick fixes have not entirely solved the issues we're seeing with connected Microsoft accounts. We're now investigating details and reproducing issues in a controlled environment so we can make a more robust fix. We recommend holding back with sending emails through Microsoft accounts until these issues have been fixed.

  • Identified
    Identified

    We have identified an additional issue where users with connected Microsoft accounts/emails are not able to send emails even after refreshing their connected account. We are working on a fix.

  • Monitoring
    Monitoring

    We have applied a fix to the error handling so users should now see a better error message when sending email fails. Users will still have to reconnect their Microsoft account if there are errors.

  • Identified
    Identified

    Some users are experiencing issues sending emails via their connected Microsoft account/email. Unfortunately, the error occurring is not handled well in the system and leads to confusing error messages. Users will have to reconnect their Microsoft account. We are working on providing better error messages for this issue.