Started over 1 year agoMarch 21, 2025Lasted 10 minutesMarch 21, 20251:151:24 PMUTC
Affected
Web Application
Degraded performance from 1:15 PM to 1:24 PM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Investigating
UTC
Investigating
UTC
We are having connection issues to a server running background jobs, which affects report generation, list metrics, timer editing and several other aspects of the UI. We are currently investigating this incident.