Myphoner - Outlook 365 integration broken – Incident details

Outlook 365 integration broken

Resolved
Operational
Started over 7 years agoLasted about 5 hours
Updates
  • Resolved
    Resolved

    We have fixed an issue with connecting Outlook 365 - if you are having trouble sending email, please try to reconnect your outlook 365 account.

  • Identified
    Identified

    We've identified the issue and a fix is being deployed.

  • Investigating
    Investigating

    We are currently investigating several failed connections to outlook 365.